Proceso inicio
 dia<-0;mes<-0;ano<-0; meses<-“”;
 Repetir
  Escribir “inserte dia, mes y ano”;
  Leer dia, meses, ano;
  si meses=”enero” Entonces
   mes<-1
   sino si meses=”febrero” Entonces
    mes<-2
    sino si meses=”marzo” Entonces
     mes<-3
     sino si meses=”abril” Entonces
      mes<-4
      sino si meses=”mayo” Entonces
       mes<-5
       sino si meses=”junio” Entonces
        mes<-6
        sino si meses=”julio” Entonces
         mes<-7
         sino si meses=”agosto” Entonces
          mes<-8
          sino si meses=”setiembre” Entonces
           mes<-9
           sino si meses=”octubre” Entonces
            mes<-10
            sino si meses=”noviembre” Entonces
             mes<-11
             sino si meses=”diciembre” Entonces
              mes<-12
             FinSi
            FinSi
           FinSi
          FinSi
         FinSi
        FinSi
       FinSi
      FinSi
     FinSi
    FinSi
   FinSi
  FinSi
  dia<-dia+1
  si ano<1 Entonces
   ano<-0
  FinSi
  si mes<1 o mes>12 Entonces
   mes<-0
  FinSi
  si mes=4 o mes=6 o mes=9 o mes=11 Entonces
   si dia=31 Entonces
    mes<-mes+1
    dia<-1
   FinSi
   si dia<1 o dia>30 Entonces
    dia<-0 
   FinSi
   sino si mes=1 o mes=3 o mes=5 o mes=7 o mes=8 o mes=10 o mes=12 Entonces
    si dia=32 Entonces
     mes<-mes+1
     dia<-1
    FinSi
    Si dia<1 o dia>31 Entonces
     dia<-0
    FinSi
    sino si mes=2 Entonces
     si ano mod 4 =0 Entonces
      si dia=30 Entonces
       mes<-mes+1
       dia<-1
       sino si dia<1 o dia>29 Entonces
        dia<-0
       FinSi
      FinSi
      sino Entonces
       si dia=29 Entonces
        mes<-mes+1
        dia<-1
       sino si dia<1 o dia>28 Entonces
        dia<-0
       FinSi
      FinSi
     FinSi
    FinSi
   FinSi
  FinSi
  si mes=13 Entonces
   ano<-ano+1
   mes<-1
  FinSi
  si mes=1 Entonces
   meses<-“enero”
   sino si mes=2 Entonces
    meses<-“febrero”
    sino si mes=3 Entonces
     meses<-“marzo”
     sino si mes=4 Entonces
      meses<-“abril”
      sino si mes=5 Entonces
       meses<-“mayo”
       sino si mes=6 Entonces
        meses<-“junio”
        sino si mes=7 Entonces
         meses<-“julio”
         sino si mes=8 Entonces
          meses<-“agosto”
          sino si mes=9 Entonces
           meses<-“setiembre”
           sino si mes=10 Entonces
            meses<-“octubre”
            sino si mes=11 Entonces
             meses<-“noviembre”
             sino si mes=12 Entonces
              meses<-“diciembre”
             FinSi
            FinSi
           FinSi
          FinSi
         FinSi
        FinSi
       FinSi
      FinSi
     FinSi
    FinSi
   FinSi
  FinSi
  si dia=0 o mes=0 o ano=0 Entonces
   si dia=0 Entonces
    Escribir “ERROR AL INSERTAR DIA”
   FinSi
   si mes=0 Entonces
    Escribir “ERROR AL INSERTAR MES”
   FinSi
   si ano=0 Entonces
    Escribir “ERROR AL INSERTAR ANO”
   FinSi
  sino Entonces
   Escribir “dia “,dia,” mes “,meses,” ano “,ano;
  FinSi
  Escribir “¿desea finalizar proceso?”
  Escribir “si haci es digite S de si”;
  Leer meses
 Hasta Que (meses=”s” o meses=”S”)
 Escribir “gracias por su preferencia”
FinProceso

Anuncios